BIOCs
APIs for managing BIOCs
Return a list of BIOCs. You can return all BIOCs or filter results. You can also return extended results with all details included.- The response is concatenated using AND condition (OR is not supported).
The maximum result set size is >100.
Offset is the zero-based number of incidents from the start of the result set.
You must have Rules Edit permissions to run this endpoint.
{api_key}
{api_key_id}
OK
Bad Request. Got invalid JSON.
Unauthorized access. An issue occurred during authentication. This can indicate an incorrect key, id, or other invalid authentication parameters.
Unauthorized access. User does not have the required license type to run this API.
Forbidden access. The provided API Key does not have the required RBAC permissions to run this API.
Internal server error. A unified status for API communication type errors.
POST /public_api/v1/bioc/get HTTP/1.1
Host: api-yourfqdn
Authorization: text
x-xdr-auth-id: text
Content-Type: application/json
Accept: */*
Content-Length: 40
{
"request_data": {
"extended_view": false
}
}{
"objects_count": 2,
"objects": [
{
"rule_id": 376,
"name": "TestDataSourceTags",
"type": "OTHER",
"severity": "SEV_030_MEDIUM",
"comment": "",
"status": "DISABLED",
"is_xql": false,
"indicator": {
"runOnCGO": true,
"investigationType": "PROCESS_EXECUTION_EVENT",
"investigation": {
"PROCESS_EXECUTION_EVENT": {
"filter": {
"AND": [
{
"SEARCH_FIELD": "action_process_username",
"SEARCH_TYPE": "EQ",
"SEARCH_VALUE": "guyk",
"EXTRA_FIELDS": [],
"isExtended": false
}
]
}
}
}
},
"mitre_tactic_id_and_name": [],
"mitre_technique_id_and_name": []
},
{
"rule_id": 421,
"name": "new_bioc_test",
"type": "EXECUTION",
"severity": "SEV_020_LOW",
"comment": "",
"status": "ENABLED",
"is_xql": true,
"indicator": "dataset = xdr_data | filter event_type = 1 and actor_process_image_name = \"SDFDSGFHFN\"",
"mitre_tactic_id_and_name": [
"12 - Tactic",
"45 - Another Tactic"
],
"mitre_technique_id_and_name": [
"123 - Test",
"12 - Another Test"
]
}
],
"objects_type": "bioc"
}Insert new BIOCs or update existing BIOCs.
Note: The BIOC rule_id is tenant specific and can't be used across tenants. Inserting BIOCs with the same rule_id as an existing BIOC on that tenant will overwrite the existing BIOC.
Requires the granular RBAC permission for this feature.
{api_key}
{api_key_id}
OK
A list of errors.
Bad Request. Got invalid JSON.
Unauthorized access. An issue occurred during authentication. This can indicate an incorrect key, id, or other invalid authentication parameters.
Unauthorized access. User does not have the required license type to run this API.
Forbidden access. The provided API Key does not have the required RBAC permissions to run this API.
Internal server error. A unified status for API communication type errors.
POST /public_api/v1/bioc/insert HTTP/1.1
Host: api-yourfqdn
Authorization: text
x-xdr-auth-id: text
Content-Type: application/json
Accept: */*
Content-Length: 891
{
"request_data": [
{
"name": "TestBIOC",
"type": "EXECUTION",
"severity": "SEV_020_LOW",
"comment": "",
"status": "ENABLED",
"is_xql": false,
"indicator": {
"runOnCGO": true,
"investigationType": "FILE_EVENT",
"investigation": {
"FILE_EVENT": {
"filter": {
"AND": [
{
"OR": [
{
"SEARCH_FIELD": "event_sub_type",
"SEARCH_TYPE": "EQ",
"SEARCH_VALUE": "1",
"isExtended": false
},
{
"SEARCH_FIELD": "event_sub_type",
"SEARCH_TYPE": "EQ",
"SEARCH_VALUE": "2",
"isExtended": false
},
{
"SEARCH_FIELD": "event_sub_type",
"SEARCH_TYPE": "EQ",
"SEARCH_VALUE": "3",
"isExtended": false
},
{
"SEARCH_FIELD": "event_sub_type",
"SEARCH_TYPE": "EQ",
"SEARCH_VALUE": "5",
"isExtended": false
},
{
"SEARCH_FIELD": "event_sub_type",
"SEARCH_TYPE": "EQ",
"SEARCH_VALUE": "6",
"isExtended": false
}
]
},
{
"SEARCH_FIELD": "action_file_name",
"SEARCH_TYPE": "EQ",
"SEARCH_VALUE": "aaaaaa",
"EXTRA_FIELDS": [],
"isExtended": false
}
]
}
}
}
},
"mitre_tactic_id_and_name": [
""
],
"mitre_technique_id_and_name": [
""
]
}
]
}{
"added_objects": [
{
"id": 34,
"status": "Created a new BIOC rule with the ID: 34 successfully"
}
],
"updated_objects": [],
"errors": []
}Delete BIOCs selected by filter.
Requires the granular RBAC permission for this feature.
{api_key}
{api_key_id}
OK
Number of BIOC objects deleted.
Bad Request. Got invalid JSON.
Unauthorized access. An issue occurred during authentication. This can indicate an incorrect key, id, or other invalid authentication parameters.
Unauthorized access. User does not have the required license type to run this API.
Forbidden access. The provided API Key does not have the required RBAC permissions to run this API.
Internal server error. A unified status for API communication type errors.
POST /public_api/v1/bioc/delete HTTP/1.1
Host: api-yourfqdn
Authorization: text
x-xdr-auth-id: text
Content-Type: application/json
Accept: */*
Content-Length: 111
{
"request_data": {
"extended_view": false,
"filters": [
{
"field": "severity",
"operator": "EQ",
"value": "SEV_020_LOW"
}
]
}
}{
"objects_count": 3,
"objects": [
1,
3,
7
]
}Last updated
Was this helpful?
