For the complete documentation index, see llms.txt. This page is also available as Markdown.
Cortex XDR 3.x

len

Learn more about the Cortex Query Language len function that returns the number of characters contained in a string.

Syntax

len (<string>)

Description

The len() function returns the number of characters contained in a string.

Examples

Show domain names that are more than 100 characters in length.

dataset = xdr_data 
| fields dns_query_name 
| filter len(dns_query_name) > 100 
| limit 10 

Last updated

Was this helpful?