Cortex XDR 3.x
uppercase
Learn more about the Cortex Query Language uppercase() function that converts a string field to all uppercase letters.
Syntax
uppercase (<string>)Description
The uppercase() function converts a string field value to all uppercase.
Examples
Convert all actor_process_image_name field values that are not null to uppercase, and return a list of unique values.
dataset = xdr_data
| fields actor_process_image_name as apin
| dedup apin by asc _time
| filter apin != null
| alter apin = uppercase(apin)Last updated
Was this helpful?
