> For the complete documentation index, see [llms.txt](https://cortex-docs.paloaltonetworks.com/llms.txt). Markdown versions of documentation pages are available by appending `.md` to page URLs; this page is available as [Markdown](https://cortex-docs.paloaltonetworks.com/cortex-xsiam/reference-and-developer-docs/cortex-agentix-xql/get-started-with-xql/xql-language-structure.md).

# XQL Language Structure

Learn about XQL language structure for creating queries in Cortex XSIAM.

Cortex Query Language (XQL) queries usually begin by defining a data source, be it a dataset, preset, or Cortex Data Model (XDM). You must specify the dataset mapped to the XDM that you want to run your query against. In a dataset query, unless otherwise specified, the query runs against the `xdr_data` dataset, which contains all log information that Cortex AgentiX collects from all Cortex product agents, including EDR data, and PAN NGFW data. It's possible to change the default dataset in the **Dataset Management** page of Cortex XSIAM. For more information, see [What are datasets?](/cortex-xsiam/configure-cortex-xsiam/data-management/dataset-management/what-are-datasets.md).

After specifying a data source, you use zero or more stages to form the XQL query. Each stage is delimited using a pipe character (`|`). The function performed by each stage is identified by the stage keyword that you provide. XQL queries can contain different components depending on the type of query you want to build.

### **Adding comments in queries**

You can add comments in any section when building a query in Cortex Query Language (XQL).

* Comments are added on a single line using the following syntax.

  ```programlisting
   //<comments>
  ```

  For example,

  ```programlisting
  dataset = xdr_data
  | filter event_type=1
  //ENUM.process
  and event_sub_type = 1
  //ENUM.execution
  ```
* To write a comment that extends over multiple lines use the following syntax.

  ```programlisting
  /*multi-line <comments> */
  ```

  For example,

  ```programlisting
  dataset = xdr_data 
  | filter 
  /*multi-line Adding comments is a great thing.
  Here is an example */ 
  event_type=1
  ```


---

# Agent Instructions
This documentation is published with GitBook. GitBook is the documentation platform designed so that both humans and AI agents can read, navigate, and reason over technical content effectively. Learn more at gitbook.com.

## Querying This Documentation
If you need additional information that is not directly available in this page, you can query the documentation by asking a question.

Perform an HTTP GET request on the following URL with the `ask` and `goal` query parameters:

```
GET https://cortex-docs.paloaltonetworks.com/cortex-xsiam/reference-and-developer-docs/cortex-agentix-xql/get-started-with-xql/xql-language-structure.md?ask=<question>&goal=<user_goal>
```

`ask` is the immediate question: it should be specific, self-contained, and written in natural language.
`goal` is what the user is ultimately trying to achieve, the reason they need the answer. Sharing it helps GitBook give you a better, more relevant answer. A goal is most helpful when it describes the outcome the user wants rather than restating the question. For example, with `ask=how do I create an API token`, a goal like `automate deployments from our CI pipeline` lets GitBook tailor the answer to that use case.

The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
