Troubleshoot Engine Installation
Troubleshoot engine installation in Cortex XSOAR 6.13.
After installing the engine, check that the XSOAR engine is connected to the main server and that it is running.
Go to Settings → INTEGRATIONS → Engines and verify that the engine is connected.

engines-troubleshooting-connected.png If the engine is not connected, run the following command on the engine server to check if the engine service is running.
sudo systemctl status d1Access the d1 log on the engine server.
sudo tail -f /var/log/demisto/d1.logIf the engine service wasn’t running, and there’s nothing relevant in the log, run
journalctlon the engine server to understand why the installation failed.If the engine service is running, review the errors to see if the engine is failing to connect or if there are other issues. (Ignore all errors related to \d2ws, since this is not the same as d1ws.) Most often, the server address is incorrect and you will see an error like this:
error Cannot connect to [wss://<mainServerIP/HostName>/d1ws]: wss://<mainServerIP/HostName>/d1ws: dial tcp: lookup localhost: no such host. . Waiting 3 seconds. Will try until…In this case, navigate to
/usr/local/demisto/d1.confand change the EngineURLs parameter to an address the engine can reach. Check the addresses at the beginning of the upgrade_engine.sh file and update them to be the same as in the conf file. The addresses should be a comma-separated list.The configurations that might affect the upgrade_engine.sh script are the following variables located at the beginning of the script:
SERVER_URLSTRUST_ANY_CERT
If you make a change to the baseURLs configuration, you must apply the change in
/usr/local/demisto/d1.confAND in/usr/local/demisto/upgrade_engine.shunder the SERVER_URLS var.If you make a change in the
engine.connection.trust_any_certificateconfiguration, you must apply the change in/usr/local/demisto/upgrade_engine.shas follows:If the
engine.connection.trust_any_certificateconfiguration was set to true (trust any certificate), set the TRUST_ANY_CERT variable to -k.If the
engine.connection.trust_any_certificateconfiguration was set to false, the TRUST_ANY_CERT variable should be blank (““).
To check the connectivity from the engine to the main server, see Troubleshoot Engine Connectivity.
If the installation issue remains, open a support case with logs from the main server and engine.
On the engine server, in
/usr/local/demisto/d1.conf, set "LogLevel": "debug”.On the main server, navigate to Settings → ABOUT → Troubleshooting and verify that the Log Level is set to Debug.
Restart the d1 service and let it run for a few minutes.
sudo systemctl restart d1On the main server, go to Settings → ABOUT → Troubleshooting → Download logs to download a log bundle.
Capture a journalctl:
journalctl --since "1 day ago" > engineTroubleshootingJournalctl.logOn the engine server, tar up the logs, conf, journalctl, and install log on the engine.
tar -cvzf engineLogs.tar.gz /var/log/demisto /usr/local/demisto/d1.conf /tmp/demisto_install.log engineTroubleshootingJournalctl.log
Last updated
Was this helpful?
