Maintenance Releases in Cortex XSOAR 8.10
Maintenance Releases for Cortex XSOAR 8x On-prem.
August 10, 2026 (master-8.10.0-8.10.0.35-ff14929d)
This maintenance release includes the following bug fix:
Fixed an issue where the apt package upgrade caused system upgrade to fail.
July 13, 2026 (master-8.10.0-8.10.0.34-358dbc86)
This maintenance release includes the following bug fixes:
Fixed multiple upgrade and infrastructure issues.
Added one-click sequential upgrades to enable upgrading to a target version in a single action from the textual UI.
January 7, 2026 (master-8.10.0-8.10.0.28-2e42815c)
This maintenance release includes the following bug fixes:
Fixed an issue where accumulated audit logs consumed disk space and impacted system stability. The system now automatically compresses audit logs and retains them for six months before deletion.
Fixed an issue where the
!SSDeepReputationbuilt-in command did not correctly identify and return similar indicators.Upgraded the Go version to fix security vulnerabilities.
November 5, 2025
This maintenance release includes the following bug fixes:
An upgrade issue from 8.9 to 8.10 was caused by a missing CoreDNS image.
A potential soft lock issue caused by a bad kernel version was fixed.
A security setting that could permanently lock out default Linux admin and viewer system users was fixed, ensuring these users can now change their passwords after expiration without being locked out.
Required ports for standalone and cluster communication were clarified.
August 25, 2025
This maintenance release includes the following bug fixes:
In the welcome notes, the release notes link referred to Cortex XSOAR SaaS and not to Cortex XSOAR 8.10 On-prem.
(Multi-tenant) Content from the main tenant appeared when opening a new browser tab in My Incidents on the child tenant. Also, opening another incident in a new tab, reverted to the main tenant.
Additionally, the My Incidents tab disappeared from the sidebar when the incident was initially opened.
An error occurred when navigating to a parent playbook from a sub-playbook in the Work Plan using the back icon (located next to the sub-playbook name/title).
Sub-playbooks failed to load from the Work Plan, displaying an infinite loading spinner, because the system attempted to access an incorrect URL.
Several security vulnerabilities were detected and fixed in the OpenSSH Debian package.
An error occurred when uploading a file (less than 25MB) using the
uploadfilecommand or theuploadAPI request. The limit has now been increased to 25MB.
Last updated
Was this helpful?
